So I had some trouble with Activesupport and CarrierWave when upgrading to Rails 3.1, so I’m putting my solution here, hopefully for others to enjoy. I got this error:

Bundler could not find compatible versions for gem “activesupport”:
In Gemfile:
rails (= 3.1.1) depends on
activesupport (= 3.1.1)

carrierwave depends on
activesupport (3.0.10)

And the solutions was to do the bundle update command

bundle update

Or, if you like me are using rvm

rvmsudo bundle update

And now everything works just perfect ^^